Verification is currently underway for the maintenance items.
Posted May 24, 2021 - 19:05 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 24, 2021 - 19:01 AEST
Update
The new security certificates are valid for 1 year and have a new expiry date of Fri, 27 May 2022 23:59:59 GMT.
For our security conscious customers that might be performing their own certificate validations; in preparation for the maintenance window, refer to the below links to download the new security certificates.
On Mon, May 24 2021 09:00:00 GMT we will be performing routine maintenance to renew the security certificates of *.open360.com and *.openfreight.com.au which will expire on Thu, 27 May 2021 23:59:59 GMT.
Posted May 14, 2021 - 15:17 AEST
This scheduled maintenance affected: Website, Open360 Service Desk (Open360 Service Desk (United States), Open360 Service Desk (Europe), Open360 Service Desk (Australia)), Open360 Billing (Open360 Billing (United States), Open360 Billing (Europe), Open360 Billing (Australia)), and Open360 Freight (Open360 Freight (United States), Open360 Freight (Europe), Open360 Freight (Australia)).